Download
Recent Updates

MOBILE SYNC GUIDES
Mobile Device Syncing
Android Syncing
iPhone/iPad Sync

HELP/SUPPORT
Getting Started Guide
Support



gSyncit Download

CURRENT RELEASE: v3.8.148 

 

NOTE: 64-bit version requires Outlook 2010/2013 64-bit and not just Windows 64-bit. Otherwise, install the 32-bit version. You can confirm the "bit" version of Outlook used on Outlook File / Help or File / Accounts panel.

IMPORTANT INFORMATION REGARDING GOOGLE CALENDAR SYNC


ON NOVEMBER 17TH, 2014 GOOGLE WILL STOPPED SUPPORTING THE GOOGLE CALENDAR SERVICE USED BY GSYNCIT V1, V2 AND V3. THIS WAS AN UNEXPECTED ACCOUNCEMENT THAT PREVENTS THE CALEDNAR SYNC FROM WORKING WITH THESE RELEASES OF GSYNCIT. ALL OTHER SYNC FUNCTIONALITY WILL CONTINUE TO WORK.

OUR GSYNCIT V4 SOFTWARE, BASED ON THE NEWER GOOGLE API PLATFORM, WORKS WITH THE NEW GOOGLE CALENDAR V3 SERVICE IN ADDITION TO MANY OTHER IMPROVEMENT AND ENHANCEMENTS.   

This software requires a license key to remove any feature limitation.

The unregistered version is limited to synchronizing one Google and Outlook calendar, synchronizing 50 contacts/note/tasks entries and does not sync deletes for contacts/notes/tasks entries. Registration will remove these limitations and remove any registration/nag dialogs from the application. 

If you have any problems download gSyncit try clearing your browser cache and download gSyncit to your desktop first. Then install gSyncit from your desktop.

REQUIREMENTS

  • Microsoft .Net Framework 4.0 (Preinstalled with Windows 8)
  • Microsoft Windows XP / Vista (32 & 64 Bit) / Windows 7 (32 & 64 Bit) / Windows 8 (32 & 64 Bit)
  • Microsoft Outlook XP (2002), Outlook 2003, Outlook 2007, Outlook 2010, Outlook 2013

Microsoft Outlook 2011 for Mac NOT supported.